在使用IMBox的环境下的system.log中输出 [E.IWP.IMBOX.COMMON.00008] 或者[E.IWP.IMBOX.COMMON.00005] 等错误。

 
【现象】
在使用IMBox的环境下的system.log中输出以下错误。

・[E.IWP.IMBOX.COMMON.00008] 在MessageColumnFamily中没有值,或被逻辑删除。输入值 [threadId:xxxxx]
・[E.IWP.IMBOX.COMMON.00005] 在UserColumnFamily中没有值,或被逻辑删除。输入值 [userCd:xxxxx]

【原因】
Apache Cassandra 的数据中可能出现不一致。

【解决方法】
通过以下2个操作可能会改善。
通过执行任意1个操作也可能会改善。

1. 修复Apache Cassandra的数据。

     1-1. 停止所有intra-mart AccelPlatform。
            为了禁止访问Apache Cassandra服务器,进行停止。

     1-2. 确认所有Apache Cassandra服务器都在启动。
           如果未启动,请让所有Apache Cassandra服务器都启动。
           在只有一台Apache Cassandra服务器的情况下,即使处于停止状态也没问题。

     1-3. 在所有Apache Cassandra服务器中执行以下命令。

               %CASSANDRA_HOME%/bin/nodetool repair -pr

           此外,在只有一台Apache Cassandra服务器的情况下,即使通过以下命令,也将进行与上述命令相同的处理。

               %CASSANDRA_HOME%/bin/nodetool repair

    1-4. 如果Apache Cassandra服务器处于停滞状态,就让它启动。

    1-5. 启动所有intra-mart AccelPlatform。

2. 执行数据重建Jobnet。

    2-1. https://www.intra-mart.jp/document/library/iap/public/imbox/imbox_specification/texts/base/federation/jobscheduler/index.html#jobnet-data-rebuild

-- 适用对象 --------------------------------------------------------------
iAP/Accel Platform/所有更新版本
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